콘텐츠 목차
ㆍ도메인 연결 시 SSL이 자동으로 발급되는데 이 부분이 법적 의무 사항인가요?
ㆍhttps 적용 후 사이트 접속 시 유효하지 않은 인증서라는 안내가 떠요.
ㆍhttps 주소로 접속 시 '이 웹 사이트의 보안 인증서에 문제가 있습니다'라는 보안경고창이 떠요.
SSL이란 무엇인가요?
SSL(Secure Sockets Layer) 이란?
브라우저와 서버 간의 통신에서 정보를 암호화함으로써 도중에 해킹을 통해 정보가 유출되더라도 정보의 내용을 보호할 수 있게 해 주는 보안 솔루션이에요.
보안이 적용된 웹사이트의 접속주소는'http://' 대신 'https://'로 접속해요.
도메인 연결 시 SSL이 자동으로 발급되는데 이 부분이 법적 의무 사항인가요?
개인정보가 송수신되지 않은 페이지라면 SSL 설치가 의무는 아니예요.
카페24 쇼핑몰 솔루션은 기본적으로 로그인, 회원가입, 주문서 작성 등의 주요 영역의 개인정보 통신구간에 대해 적용이 되어 있으며, 접속한 도메인과 관계없이 페이지 이동 시 개인정보는 암호화되어 처리되고 있어요.
또한, 쇼핑몰 내 도메인의 연결로 인하여 발급 및 설치되고 있는 SSL인증서는 무료로 발급되고 있는 SSL인증서이기 때문에 해지기능은 제공되지 않아요.
https 적용 후 사이트 접속 시 유효하지 않은 인증서라는 안내가 떠요.
유효하지 않은 인증서라고 나오는 이유
https 적용 후 사이트 접속 시 '유효하지 않은 인증서'라는 내용의 안내가 뜨는 것은 사이트 내 콘텐츠 중 유효하지 않은 인증서를 사용하고 있는 콘텐츠가 있기 때문이에요. https 형태로 접속이 되지 않는 도메인이 포함되어 있는지 확인해주세요.
디자인을 수정해주세요
페이지 디자인 수정으로 해결할 수 있으며 자세한 디자인 수정 방법은 연결된 FAQ를 확인해주세요.
※ 디자인 수정 시 PC, 모바일 모두 체크해야 해요.
https 주소로 접속 시 '이 웹 사이트의 보안 인증서에 문제가 있습니다.'라는 보안경고창이 떠요.
https 주소 접속과 SSL 설정
https 주소로 웹사이트에 접속 시 보안 경고창이 표시되는 경우에는 SSL 설정이 필요해요.
SSL은 인증서 신청(발급) 후 디자인 변경까지 진행해야 적용되므로 디자인 변경 가이드도 꼭 확인해주세요.
※ SSL 설정이 되어 있지 않아도 네이버 검색 결과에 https가 붙은 도메인 주소로 검색될 수 있어요.
이러한 경우에는 네이버 서치 어드바이저에서 https로 설정이 되어 있는지 확인이 필요하며,
http 도메인 주소로 노출되기를 원하는 경우에는 네이버로 요청해주세요.
Note - 스크립트 삽입 전 주의사항
-
SSL 설치가 되었는지 확인해주세요.
-
https 접속 시 모든 콘텐츠가 정상적으로 표시되는지 확인 후 삽입해주세요.
SSL 인증서가 등록 완료 된 사이트인데 특정 사용자만 정상 접속 되지 않아요.('연결이 비공개로 설정되어 있지 않습니다.' 메세지 노출)
발생 현상
사이트 접속 시 '연결이 비공개로 설정되어 있지 않습니다.' 와 같은 경고 창이 노출돼요.
원인
루트 인증서(DST Root CA X3)가 2021년 9월 30일 만료로 인해 변경되었어요.
하위 버전의 OS를 사용하는 경우, 혹은 고객이 접속하신 기기가 최신 OS를 사용 중일지라도
루트 인증서가 누락되어 있는 경우에는 https로 사이트 접속 시 `신뢰하지 않는 인증서로 표시` 될 수 있어요.
해결 방법
수동으로 루트 인증서 설치 방법
- 인증서 발급 기관 사이트
Info
접속 시 안전하지 않은 사이트로 노출되는 경우
하단의 `고급` 버튼을 선택 후 `안전하지 않음`을 선택해 접속해주세요.
에 접속하여 인증서 파일을 PC에 다운로드 받아 주세요. - 저장된 파일을 우클릭하여 `인증서 설치`를 클릭해주세요.
- 인증서 설치 화면에서 '로컬 컴퓨터'를 선택 후 다음 버튼을 클릭해주세요.
- 인증서 가져오기 마법사 창이 열리면 '모든 인증서를 다음 저장소에 저장'을 선택한 후,
찾아보기 버튼을 클릭하여 인증서 저장소를 '신뢰할 수 있는 루트 인증 기관'으로 선택해주세요. - '다음' 버튼을 클릭하면 인증서가 설치 완료되니 '마침'을 클릭 후 재부팅 해주세요
※ 참고)
크롬으로 쇼핑몰 접속 시 악성코드가 발견되었다는 메시지가 나와요.
현재 주로 사용되는 인터넷 브라우저는 인터넷 익스플로러 외에도 크롬, 사파리 등의 다양한 브라우저도 많이 사용되고 있어요.
크롬 브라우저에서 쇼핑몰에 접속할 경우 악성코드가 발견되었다는 메시지가 노출되는 경우가 있는데
이럴 때는 Google Search Console에서 해결할 수 있으니 운영하실때 참고해주세요.
처리 방법
- 문제가 되는 악성코드를 삭제 해주세요.
- 로그추적을 하는 외부 스크립트 등을 악성코드로 인식하는 경우도 있어요.
- 에 접속을 합니다.(본인의 구글 계정으로 접속을 합니다.)
- 시작하기를 클릭하여 본인의 쇼핑몰 url을 입력 후 [계속]을 클릭하세요.
- 도메인에 대한 소유권 확인을 구글의 안내에 따라 진행해주세요.
- 악성 소프트웨어를 배포하는지 확인하고 싶은 페이지에서 자세한 내용을 클릭해주세요.
- 검토 요청을 하면 끝이예요.
Info
- Google에서 처리하는 내용이며, 적용까지는 최대 1주~2주가 소요될 수 있어요.